Home > LDom > Can’t start virtual switch vsw after Ldom restart

Can’t start virtual switch vsw after Ldom restart

November 15, 2010 Leave a comment Go to comments

Symptoms

vsw2: DL_ATTACH_REQ failed: DL_SYSERR (errno 22)
vsw2: DL_BIND_REQ failed: DL_OUTSTATE
vsw2: DL_PHYS_ADDR_REQ failed: DL_OUTSTATE
vsw2: DL_UNBIND_REQ failed: DL_OUTSTATE
Failed to plumb IPv4 interface(s): vsw2

Findings

The virtual switch primary-vsw2 is missed after Ldom get restarted

# ldm list-services
VCC
NAME             LDOM             PORT-RANGE
primary-vcc0     primary          5000-5100

VSW
NAME             LDOM             MAC               NET-DEV   ID   DEVICE     LINKPROP   DEFAULT-VLAN-ID PVID VID                  MTU   MODE
primary-vsw0     primary          00:14:4f:f8:83:d7 e1000g3   0    switch@0              1               1                         1500
primary-vsw1     primary          00:14:4f:f8:48:60 e1000g1   1    switch@1              1               1                         1500

 

Fixed

ldm add-vsw net-dev=e1000g2 primary-vsw2 primary

 

Advertisements
Categories: LDom
  1. No comments yet.
  1. No trackbacks yet.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: